Mail114 Disruption to email service
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 12, 2017 - 09:28 BST
Investigating
We have identified an issue on mail114 which is affecting email flow, emails sent to and from domains on this mail-server are still pending delivery in the mail queue.

We are investigating the cause of this issue and expect to have this back to normal operation as soon as possible.
Posted 2 months ago. Aug 12, 2017 - 08:23 BST