Top level domain Renewals, Registrations, Updates failures
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 15, 2019 - 11:31 BST
Investigating
We are currently experiencing issues making modifications to top level domain name extensions such as .COM .ORG .NET, this will affect renewals / registrations / modifications to contact details / changing name servers.

We apologise for any inconvenience caused.
Posted about 1 month ago. Jun 15, 2019 - 10:44 BST