Customer connectivity issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Dec 09, 2017 - 17:41 GMT
Investigating
Some customers are experiencing some connectivity issues when logging into or accessing their accounts, this is currently being investigated by our System Administrators and we hope to get this resolved as soon as possible, we do apologise for any inconvenience caused.
Posted Dec 09, 2017 - 16:46 GMT