Premium Hosting Connectivity Issues
Incident Report for Heart Internet
Resolved
This incident has now been resolved.
Posted 3 months ago. Dec 11, 2018 - 14:58 GMT
Investigating
We're aware that customers who use our Premium Hosting services may experience problems accessing their sites at this time.

Our teams are investigating this and will provide updates shortly.
Posted 3 months ago. Dec 11, 2018 - 14:14 GMT
This incident affected: Premium Hosting.