Receiving email delay to newly created mailboxes for a small number of customers
Incident Report for Heart Internet
Resolved
This has now been resolved
Posted Jan 08, 2017 - 16:21 GMT
Monitoring
There may be a delay in being able to receive email for a small number of newly created mailboxes.

This issue is in the process of being resolved and we apologise for the inconvenience caused.
Posted Jan 07, 2017 - 19:15 GMT