Phone connectivity issues
Incident Report for Heart Internet
Resolved
This incident has now been resolved.
Posted 6 months ago. May 03, 2018 - 15:13 BST
Identified
Some customers may experience connectivity issues when attempting to contact our support teams via Livechat and or the ticketing system. Our system engineers are aware of this and are working towards a resolution.

If you are experiencing such issues, please raise a ticket or use our "live help" service via the ticketing system page

https://customer.heartinternet.uk/manage/ticket.cgi

Thank you for your patience.
Posted 6 months ago. May 03, 2018 - 13:56 BST