Domain Search Unavailable
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 24, 2019 - 01:08 GMT
Investigating
We are aware that our domain search is currently unavailable. During this time any attempts to search for new domains will fail. Our engineers are working to resolve this as soon as possible.

We apologise for any inconvenience caused.
Posted 5 months ago. Jan 23, 2019 - 21:05 GMT