Connectivity issues on Mail177
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 10, 2018 - 12:04 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Oct 10, 2018 - 11:39 BST
Investigating
We have identified an issue affecting mailboxes on mail177, we expect to have these problems resolved as soon as possible. Please accept our apologies for any inconvenience.
Posted 2 months ago. Oct 10, 2018 - 11:01 BST