Email
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Oct 23, 2019 - 04:56 BST
Investigating
We're aware of an issue with logins to mailboxes on some of our shared hosting mail servers. We're working on it. Thanks for your patience.
Posted Oct 23, 2019 - 04:06 BST
This incident affected: Mailservers.