Mail delivery issues
Incident Report for Heart Internet
Resolved
No further issues have been identified.
Posted Feb 11, 2020 - 20:05 GMT
Identified
The issue had been identified and a fix has been implemented however some emails may be delayed.
Posted Feb 11, 2020 - 15:28 GMT
Investigating
We are currently seeing abnormal behaviour on our mailservers, some customers are unable to send or receive, we are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted Feb 11, 2020 - 14:26 GMT
This incident affected: Mailservers.