Webmail Connectivity
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jan 30, 2020 - 12:36 GMT
Investigating
We are aware that customers who use our webmail interface at www.outitgoes.com may be experiencing issues connecting to the service. We are looking into this.

Connections via desktop/mobile clients will not be affected by this.
Posted Jan 30, 2020 - 10:46 GMT