Live chat service
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 01, 2018 - 13:11 BST
Monitoring
The service is now working again, though Intermittent issues may still persist.
Posted 3 months ago. Sep 27, 2018 - 09:28 BST
Investigating
Our live chat service is currently down. Our apologies for the inconveniences while we look to resolve this as soon as possible.
Posted 3 months ago. Sep 26, 2018 - 11:07 BST