Connectivity issues on Mail 124
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 17, 2018 - 15:59 BST
Update
We have seen improved performance and no further issues relating to this mail server, we will continue to monitor this for the next 24 hours.
Posted 2 months ago. Oct 14, 2018 - 13:39 BST
Update
We're seeing improved performance on this server following works carried out today to move some mailboxes to other servers.

We're going to continue to monitor the server and will provide further updates tomorrow.
Posted 2 months ago. Oct 12, 2018 - 23:30 BST
Update
The mail server is still under high load, resulting in limited and unreliable mail connections.

We are trying to increase available connections whilst also balancing this increase against the load increasing further. This balancing is only a short term solution, our System Administrators are looking at a way to reduce the load and allow all connections to be made correctly to the mail server.

The current plan to resolve this is to move specifically selected domain's mailboxes off the mail server and then on to another mail server which should reduce the load dramatically. These domains have been selected as they are the largest legitimate consumers of resources on the server and limiting the total number of domains moved makes the process as fast and efficient as possible.

These migrations have been completing steadily and we expect the last ones that will be required to be finished by the end of the day today, though performance has already been improving once the migrations have finished this will free up even more resources in itself and we are confident that should resolve the issue almost completely and further impact should be minimal if it's present at all. Our System Administrators have already taken action identifying and disabling any services that can be currently considered extraneous.
Posted 2 months ago. Oct 12, 2018 - 14:26 BST
Update
We are still monitoring the connectivity of mail124, and are in the process of implementing a resolution. We will provide further updates when we have this available.
Posted 2 months ago. Oct 12, 2018 - 09:27 BST
Update
At this moment in time we are continuing the monitor the changes which have been made over the last 24 hours which have allowed some additional connectivity to mail124. We understand that some users will still experience difficulties in connecting and we will look into further ways of improving this as soon as possible.
Posted 2 months ago. Oct 11, 2018 - 23:45 BST
Update
Further changes are still being carried out which will resolve the underlying problem and return a greater level of stability to this server. We hope you continue to be patient with us.
Posted 2 months ago. Oct 11, 2018 - 15:29 BST
Update
We have made an alteration this morning which should help with the connection problems, there will still be a reduction in the stability at the moment, however we are working on a solution to this problem and intend to get this done as soon as possible.

We will keep this status page updated with the latest. Again, we apologise for the inconvenience caused.
Posted 2 months ago. Oct 11, 2018 - 11:40 BST
Update
We are still looking into this and hope to have more information shortly.
Posted 2 months ago. Oct 11, 2018 - 08:43 BST
Update
We are continuing to work on improving services on mail124, in the mean time those with mailboxes on this server may experience difficulties accessing their emails. We hope to have this sorted as soon as possible.
Posted 2 months ago. Oct 10, 2018 - 22:45 BST
Update
We are continuing to monitor mail124 whilst our teams work to improve stability for those users who are still experiencing problems.
Posted 2 months ago. Oct 10, 2018 - 17:08 BST
Monitoring
Mail flow has returned to an acceptable level and the mail server is performing better, some users may notice intermittent problems as we further make changes to help mitigate and resolve this problem.
Posted 2 months ago. Oct 10, 2018 - 14:59 BST
Identified
We are currently seeing a partial loss of external connectivity to this server, this is currently being investigated and we expect to have this back to normal operation as soon as possible. We apologise for the inconvenience caused.
Posted 2 months ago. Oct 10, 2018 - 12:47 BST
Update
Further problems were identified of which caused the server to delay emails, this has now been resolved and mail flow is returning to a steady pace.

We apologise for the inconvenience.
Posted 2 months ago. Oct 10, 2018 - 09:16 BST
Monitoring
Mail services on mail124 should be back to normal now.

Please advise our teams if you encounter further problems.
Posted 2 months ago. Oct 09, 2018 - 23:39 BST
Update
We are continuing to investigate problems on mail124. At this moment in time we understand that users may not be able to log into mailboxes or send/receive emails.

We're working to resolve this as soon as possible.
Posted 2 months ago. Oct 09, 2018 - 20:15 BST
Update
We are continuing to investigate this and expect to have this resolved shortly.
Posted 2 months ago. Oct 09, 2018 - 17:12 BST
Investigating
We are currently experiencing some temporary connectivity issues with Mail 124. This has been identified and is currently being resolved.
Posted 2 months ago. Oct 09, 2018 - 14:40 BST
This incident affected: Mailservers.