Slow Webmail Performance
Incident Report for Heart Internet
Resolved
We have resolved the problem causing the poor performance.
Posted 6 months ago. May 16, 2018 - 11:08 BST
Investigating
We're currently seeing decreased performance on webmail which may prevent users from logging in. This if not affecting those who connect to mail clients via POP3 and IMAP.

Our teams are looking into this and we hope to have things back to normal as soon as possible.
Posted 6 months ago. May 16, 2018 - 10:41 BST