Premium Hosting - Connectivity Error
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 29, 2018 - 23:52 BST
Identified
We have identified an problem affecting some websites on premium hosting.

We are currently investigating this and hope to have things back to normal as soon as possible.
Posted 5 months ago. Jun 29, 2018 - 22:12 BST