Exchange Platform Connectivity
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Aug 14, 2017 - 11:22 BST
Identified
We have identified a connectivity issue with our hosted Exchange platform. We are currently working to resolve this issue as soon as possible. We apologize for any inconvenience caused by this.
Posted Aug 14, 2017 - 11:04 BST
This incident affected: Mailservers.