Webmail connectivity issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Dec 17, 2017 - 16:53 GMT
Investigating
We are currently seeing abnormal behaviour on this server, and are investigating the causes. Customers may get delays accessing www.outitgoes.com, We expect to have it back to normal operation soon, and apologise for any inconvenience caused.
Posted Dec 15, 2017 - 10:01 GMT