Mail40 - Mail delivery issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Oct 11, 2019 - 22:20 BST
Investigating
We are currently seeing abnormal behaviour on Mail40, we are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted Oct 11, 2019 - 20:08 BST