Mail Server - "mail98"
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 5 months ago. May 24, 2019 - 04:58 BST
Identified
We're aware of an issue with the shared hosting mail server "mail98". We're working on it. Thank you for your patience.
Posted 5 months ago. May 24, 2019 - 03:37 BST
This incident affected: Mailservers.