Webmail connectivity issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 14, 2019 - 15:24 BST
Investigating
We are currently seeing abnormal behaviour when attempting to access the webmail portal, we are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted about 1 month ago. Aug 14, 2019 - 11:50 BST